Issue Details (XML | Word | Printable)

Key: FDT-1825
Type: Improvement Improvement
Status: Confirmed Confirmed
Priority: Minor Minor
Assignee: FDT Team
Reporter: Andrew Macrae
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
FDT

re-use running Flash Player Debugger

Created: 14/Feb/11 08:15 PM   Updated: 22/Jun/12 06:42 PM
Component/s: Launching
Affects Version/s: FDT 4.5.2
Fix Version/s: FDT
Security Level: public

Time Tracking:
Not Specified

Environment: OX X 10.6.6

Review Type: Review by Product Owner


 Description  « Hide
Actually this is a behaviour which was recently "fixed" - but I prefer the "broken" behaviour. It has to do with the option to "close previous player" in the Start panel. At this point I can't remember whether this was enabled or disabled - probably disabled - but, once launched, the instance of Flash Player was left running and, with the next invocation of debugging, a new SWF would be opened in that same instance. It was annoying to have to manually close the previous SWF windows that tended to accumulate.
However, the current "correct" behaviour has the unfortunate defect of launching a new instance of Flash Player every time, whether or not the previous instance was closed or not (as per the option). On a heavily loaded system this launch could take 5-20 seconds which adds up quickly.
What I really want is for FDT to re-use the Flash Player instance, or to put it another way, the option be to close the previous SWF, not the player. If this isn't possible then at least go back (optionally) to the previous behaviour where the one instance of Player is re-used.

 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Alan K (Deprecated) added a comment - 06/Apr/11 05:17 PM
Gotcha,

I'm going to link this to a larger ticket so your idea isn't lost. I haven't run into this problem myself. We'll look into it.


Alan K (Deprecated) added a comment - 07/Apr/11 10:19 PM
The Launching ticket I had before doesn't make sense - this ticket being tagged as Launching and I think will work fine.