Issue Details (XML | Word | Printable)

Key: FDT-2082
Type: Featurerequest Featurerequest
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: FDT Team
Reporter: Patrick Kulling
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
FDT

Choose Target Player when creating a new Flash Project

Created: 28/May/11 10:56 AM   Updated: 22/Jun/12 06:42 PM
Component/s: Project Template
Affects Version/s: FDT 4.5
Fix Version/s: FDT 5.0
Security Level: public

Time Tracking:
Not Specified

File Attachments: None
Image Attachments:

1. project settings screen.jpg
(50 kB)


 Description  « Hide
It would be nice if the user can select a specific target player version when creating a new project on the Flash Project Settings page (see http://dl.dropbox.com/u/634251/fdt_project_settings.png).

By default the maximum version should be selected, e.g. 10.2 in the Flex 4.5 SDK, but it would be cool to have a combo box to target lower player versions too (10.2, 10.1, 10.0, 9.0).
I know this can be done via the -target-player argument in the launcher settings but it would be a benefit for new FDT users to select their target player version when setting up their project.

The minimum target player is 9.0.0 which is 'documentated' in the mxmlc help itself: mxmlc --help target-player

"-target-player <version>
gibt die Version des Players an, den die Anwendung zum Ziel hat;
Funktionen, die eine höhere Version erfordern, werden nicht in die
Anwendung kompiliert; der unterstützte Mindestwert ist "9.0.0"."



 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
No work has yet been logged on this issue.