Issue Details (XML | Word | Printable)

Key: FDT-2379
Type: Bug Bug
Status: Closed Closed
Priority: Major Major
Assignee: FDT Team
Reporter: Tobias Goeschel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
FDT

Importing older project into FDT 5 workspace causes the wizard to hang

Created: 27/Oct/11 02:13 AM   Updated: 02/Jul/12 08:27 PM
Component/s: None
Affects Version/s: FDT 5.0
Fix Version/s: None
Security Level: public

Time Tracking:
Not Specified

File Attachments: 1. Text File error.log (143 kB)

Environment:
FDT5
Mac OS X 64bit
AS3 with FlexUnit tests


 Description  « Hide
I imported an AS3 project I am currently working on from an existing FDT4.5 workspace into my newly created FDT5 workspace. The wizard started and imported the project correctly, but while I could already see the project in the Flash Explorer view in the background, the import wizard's window would not close, leaving the IDE unusable. Clicking "Finish" again prompted the message " A project named {projectname} already exists!". Clicking "Cancel" caused the cancel button to become inactive, but otherwise wouldn't do anything. And closing the window by clicking the close button in the window bar prompted a message similar to "Could not close the window due to running processes. Cancel first." There was no way out of this, and I had to force quit the IDE.

After restarting FDT5, the project appeared successfully imported and there seems to be nothing missing. I would say that makes this is a major inconvenience, but not a critical bug.



 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Meinhard Gredig added a comment - 27/Oct/11 09:35 AM
Did you use the Eclipse' import wizard? Do you have any logs in the Error Log view?

Tobias Goeschel added a comment - 27/Oct/11 02:01 PM
Yes on both:

I freshly installed FDT5 from the disk image, started it, entered my license key and changed the default SDK to Flex 4.5.1 SDK. Then I clicked "Import... >> General >> Existing projects into workspace". After that, see the description above.

The error log has several entries, most of them appearing more than once. I have worked with the project for a couple of hours since, so there are probably a number of entries that have nothing to do with the bug I described. It seems to me that there is a jar missing, and there seems to be something wrong about write permissions. I'll attach the log file (I've replaced all references to my user account and project files by {project} and {usr}).


Tobias Goeschel added a comment - 27/Oct/11 02:01 PM
Anonymized error log file.

FDT Team added a comment - 02/Jul/12 08:27 PM
Still happening?

We did have some issues when customers were upgrading from 5.0 -> 5.x.

Let us know if this continues.