Issue Details (XML | Word | Printable)

Key: FDT-2735
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: FDT Team
Reporter: Juan Fornos
Votes: 1
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
FDT

FDT won't launch after 5 -> 5.5 update

Created: 10/May/12 05:15 PM   Updated: 26/Jul/12 09:41 PM
Component/s: Launching
Affects Version/s: FDT 5.5
Fix Version/s: FDT 5.5.1
Security Level: public

Time Tracking:
Not Specified

Environment: Mac OS X 10.6.8 32 Bits

Review Type: Review by Product Owner


 Description  « Hide
The Eclipse executable launcher was unable to locate its companion shared library.

 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Will Corwin added a comment - 11/May/12 08:16 AM - edited
w7 x64. Just upgraded plugin to 5.5 using "search for updates" as well as uninstalling and attempting "install new software". Same result for both. Tried restarting, "apply changes now" and all manner of other methods to get something to work. I haven't gone as far as reinstalling ecliipse (or attempting standalone) because I do a fair amount of java work and don't wish to lose settings.

Any FDT related view prompts an error, examples being:

//Opening the perspective view
"Problems opening perspective 'com.powerflasher.fdt.ui.Perspective'

//FDT Build Path in an existing 5.0 project
"Unable to create the selected property page.
An error occurred while automatically activating bundle com.powerflasher.fdt.ui (652)"

//When I attempt to view an .as file
"Could not open the editor: The editor class could not be instantiated. This usually indicates a missing no-arg constructor or that the editor's class name was mistyped in plugin.xml."
//This is the error in the stack I get for opening an .as file.
Caused by: org.osgi.framework.BundleException: The activator com.powerflasher.fdt.ui.FDTUIPlugin for bundle com.powerflasher.fdt.ui is invalid

//At the beginning I get this
My error log contains "Unable to execute early startup code for an extension" com.powerflasher.fdt.ui.welcome.
"Plug-in com.powerflasher.fdt.ui.profiler was unable to load class com.powerflasher.fdt.ui.profiler.Startup"

//and the always useful
"Unhandled Exception"

Tried creating a new workspace, to no avail.
Using Eclipse 3.6.2

Hope something in there helps us find an answer. Clearly I'm in the minority, and I'm sure I can reinstall 5.0 without hassle but I'd like to use the new version.


Alan K (Deprecated) added a comment - 21/May/12 07:26 PM
Hey Will,

We found the issue. FDT 5.5 is not compatible with Helios (Eclipse 3.6). We rely on a structural change which only exists in Eclipse 3.7+ and is not backwards compatible.

Please upgrade your Eclipse to 3.7+ and the issue should go away. Let us know.


Philipp Arnolds added a comment - 23/May/12 05:34 PM
This issue turns out to be a general eclipse problem.
During the update process the eclipse.ini file does not get updated properly. The path of the launcher libraries does not get updated correctly. you can manually change them to resolve this issue. I have prepared a short screencast that shows how to do so: http://screencast.com/t/HB4PRlAeX

Allan Dowdeswell added a comment - 26/Jul/12 09:41 PM
Thanks for the screencast Philipp!